AutoMenを最新の6beta(2010/01/19リリース)にアップデートしてみました。

Automen
▲AutoMen6beta起動画面(クリックで拡大)

Windows7でマトモに動きませんでした。(旧バージョンも)
今まで「こんなに便利でお手軽なツールが、なぜ全く人気が無いんだろう?」って思ってましたが、安定作動する環境が限られているっぽいですね。残念。

追記

Windows7 でも安定して作動している方もチラホラといらっしゃるようです。
Intel系のCPU+OSがVista/7だと不安定になると思っていましたが違うようですね。
「安定して作動する・作動しない」の条件を特定するのが難しいツールです。。。

追記終わり。以下本文

Automen概要

AutoMenとは、エンコードエンジンにMencoderを利用した、非常に分かり易いGUIを備えたお手軽動画変換ツール。h264_mp4/x264_flv/Xvid_avi/Xvid_mkvなどに変換可能。

特にCPUがAMD系の場合、FFmpegを利用した変換ツールより数倍速いエンコードが可能。(インテル系CPUでは速度の差は殆ど無さそう)

OS:Windows (正常作動はXPのみ?)
作者:buzzqw
ライセンス:GPL・フリーウェア
ダウンロードURL:AutoMen (Mini Mencoder Gui) - Doom9's Forum
サイト内解説:MencoderをGUIで簡単に使えるフリーソフト、AutoMen(旧バージョン)

バージョンアップ雑感

GUIが洗練され、以前のバージョンでは「うっかりミス」を起こしやすかったリサイズ時のCrop指定(Cropしたくない時は手動でゼロを入力する必要があった)が自動になり、縦横比の調整も自動化。

セットアップ時にmplayer.exe、mencoder.exe、MP4Box.exeなどにパスを通す作業もいつの間にか自動化され、かなり良いカンジです。

大きく変わった所
サイズ調整
▲リサイズは赤枠で囲った部分で行う。アスペクト比を指定して、スライダーを動かせばOK。
アスペクト比と16の倍数をイチイチ計算しなくて良いので楽。

・・・が、ウチの環境では上手く動きませんでした。。。

Win7では旧バージョンも作動しなかった。。。

HDDに残っていた旧バージョン(Ver5.3、 5.1)も起動してみましたが、どうにも上手く作動しない。
XP時代には問題なく作動していたのに。。。

  1. 地デジ録画したTSファイル、Mpeg2ファイルは問題なく読める。
    (最近TSエンコしかしなかったので気が付かなかった。。。)
  2. Xvidでエンコした動画は、読めたり読めなかったり。
  3. Lagarith Losslessは全く読み込まない時が殆ど
  4. AviSynthファイルも読み込まない時が殆ど
  5. 一度TSファイルを読み込ませた後なら、Aviファイル、avsファイルが読めるようになる事もある。
  6. AVIファイルの場合、読み込みに非常に時間がかかる
    (1GBのファイルを読み込むのに10分以上)

どの辺でエラーが出ているか?

  1. ソースを正しく読み込んでくれない場合がある。
  2. 変換の時にエラーが出る場合も。
  3. MUX時にエラーの場合もあり

ソースの種類、ツール内の操作手順、あらゆる所で別のエラーが発生。
なんかお手上げっす(´Д`;)

mplayer.exe、mencoder.exe、MP4Box.exe、色々バージョンを変えてみているけど解決せず。
管理者権限で実行したり、色々するけれど変わらず。

XP時代は全く問題なく作動していたので、これはWindows7の問題か、64bit OSの問題か?
それとも何かスプリッタかコーデックが足りないのか?

ウチだけの問題じゃなさそう

Kenのムービー計画さんのAutoMenの解説ページを読むと、

  • AutoMen 6 beta 24/09/2009は不具合があったらしい。
    (現行バージョン(19/01/2010)もまだ何かおかしいかもしれない。。。)
  • Ver5.3を利用されても、ウチでは発生しなかった不具合が色々出ていらっしゃる模様
    (スクリーンショットから察するにVistaかWindows7をご利用)

AutoMenの作動はかなり環境に左右されると見て良いですね。
XP専用と考えた方が良いのかな?

とりあえず、TSファイルだけはWindows7でもエンコ可能

私が「AutoMenを使いたい時」ってのは、地デジ録画ファイル(TS)を「CMカット無しフィルタ処理も無し」でザックリ変換する時だけなので実害は殆どないのですが。。。。
(それでも音声が特殊な場合、Kenのムービー計画さんのようにエラーが出そう)

今まで「こんなに便利でお手軽なツールが、なぜ全く人気が無いんだろう?」って思ってましたが、安定作動する環境が限られているっぽいですね。残念。

先日のYouTubeに高画質アップする実験で色々なエンコーダーを再評価中に発見。