2014.11.17:登録カテゴリーの変更

既にWindows8.1のプレビュー版も公開されているし、今月末にはWindows8.1のRTM版も公開予定になっていますので ほとんど需要のない情報だとは思いますが、忘れている人の為に。

Windows 8 Enterprise 評価版のダウンロードページ
昨年公開された「Windows 8 Enterprise 90 日評価版」のライセンス認証期限は、明日8/15です。

90日試用版は、一回期限が切れたPCでもクリーンインストールすれば再び90日間利用可能になります。Windows To Goを使って外付けHDDでテスト環境を構築している人や、少しでも長くRTM版を使いたい人は、今日か明日のうちにインストール&認証しておきましょう。

Windows 8 Enterprise 90 日評価版
▲我が家では 8/13にVMware内のテスト環境を構築しなおしました。
  #16時を回った所で1日減ってしまった(^_^;
  #日数のカウントは世界標準時で行われているっぽいです。

しかしアレですねえ。カスタマイズする前のWindows8ってやっぱスゲー使い辛いです。8.1触った後だと、余計に酷く感じます(^_^;

 

おまけ: Windows8のアカウントパスワードとUACのテスト

以下、本文とは無関係な情報です。

8 月11日にコメント欄で頂いた質問の原因と対処法を、今回インストールしたWindows8 RTM環境で探ってみました。
かなり悪戦苦闘した・・・・というよりトラブルの再現性の確認すら出来ない。難しい。お手上げです。

質問内容
 ・アカウントのパスワード入力のチェックを外したら・・・
  →UACの確認ダイアログでパスワードを求められる
  →しかも「はい」のボタンがグレーアウトして使えない

「アカウントのパスワード入力のチェックを外したら・・・」
ってのは、多分以下ですよね?
ユーザーがこのコンピューターを使うには、ユーザー名とパスワードの入力が必要
▲クリックで拡大

教えて! Watch - Windows8で管理者アカウントが消失
▲多分コレと似たような症状になっている・・・または
ユーザーアカウント制御のパスワードがわかりません。 - マイクロソフト コミュニティ
▲これと似たような状態になっている・・・と予想。

これらのトラブルが発生した場合、
  • OSのアップグレードをしている場合は、以前のOSで利用していたパスワードを利用してみる
  • 何とかしてセーフモードに持ち込んで、そこからログイン情報を設定しなおしてみる
のような対処方法があるようです。
が、UACの「はい」ボタンがグレーアウトしているってのが曲者だ。。。

 

トラブル解決以前に、ウチのPC環境では上記のトラブルに陥った状態を作り出す事すら出来ません。。。

 

Windows8のアカウントパスワードとUAC
▲質問者さんと(恐らく同じであろう)PC環境を作り、PCに変更を加えてみる。
UACが反応した際に管理者のパスワードを求められるようになりましたが・・・
 ・「はい」がグレーアウトする環境を再現する事が出来ない
 ・パスワード未設定の場合は、空欄のまま「はい」クリックでOK
 ・パスワードが設定してある時はパスワード入力すればOK
色々な状況を想定してテストを繰り返していますが、特に問題発生しません。。。

ローカルアカウント作成時にパスワード未設定にしたり
ローカルアカウント作成時にパスワード未設定

さらに一般ユーザーをパスワード無しで追加したり・・・
さらに一般ユーザーをパスワード無しで追加

パスワードを再設定して、スリープ解除時に「パスワードを必要としない」に変更したり・・・
スリープ解除時に「パスワードを必要としない」
▲クリックで拡大
[コントロールパネル]>[電源オプション]>[スリープ時のパスワード保護]>[現在利用可能ではない設定を変更します]

さらには
さらに一般ユーザーをパスワード無しで追加
control userpasswords2を実行して、

ユーザーがこのコンピューターを使うには、ユーザー名とパスワードの入力が必要
▲クリックで拡大
「ユーザーがこのコンピューターを使うには、ユーザー名とパスワードの入力が必要」のチェックを外したり・・・

パスワード設定時
▲自動サインイン用のパスワードをワザと間違えてみたり、敢えて空欄にしてみたりするのですが、フツーに「パスワードが間違っています」的なメッセージが出るだけで操作不能になったりはしません。。。

色々試すけど再現しません。。。
Windows8のアカウントパスワードとUAC
▲普通にパスワード入力出来るし、管理者権限でPCの変更、プログラムのインストール、どちらも可能です。

ドコを弄ると問題の症状が発生するんだろう・・・?

 

 

何故こんなに頑張っているか・・・と云うと、実は私も以前このトラブルと似た現象をWindows7 RC版かRTM版の頃に体験しているから。しかしその時、何がトリガーになっていたのか、どうやって復旧したのか、まるで記憶なし。出来れば思い出して、きちんとメモを取っておきたい。

「ああ、Windows7でユーザーアカウントにパスワード設定しない場合は面倒な事が起きるなあ・・・面倒だけど、パスワードは設定するようにしておこう」程度には記憶しているものの、メモ等は一切残していません。
今回質問を頂いてからも、「ちょっと検証すればすぐ再現できるだろう」と思っていたのですが、再現できないです。。。

色々頑張ってみましたが、お手上げです。